Announcement

Collapse
No announcement yet.

Ride Pro e Install Tips

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ride Pro e Install Tips

    I installed my Ride Pro e system over the last few days. It works great but there are a few things that I learned along the way that may help others when they get ready to do their installs.

    First, the instructions tell you to run the ground and power wires from the ECU (control box) directly to the battery. DO NOT SHORTCUT THIS, RUN IT TO THE BATTERY!!!!

    Secondly, the instructions tell you to individually ground each sending unit directly to the battery. DO NOT SHORTCUT THIS, RUN THE SENDING UNIT GROUOND WIRE ALL THE WAY TO THE BATTERY!!!

    This system works great, but it is dependant on changes in the ohm load from the sending units to display the correct pressures on the display. The sending units are VERY sensitive and will sense the smallest ohm load changes. In my car at least, the change in ohm load from the stereo, headlights etc. had an effect on the Ride Pro E unit UNTIL I ran ALL power and ground connections ALL THE WAY TO THE BATTERY TEREMINALS.

    Save yourself (and the Air Ride Tech Guys, thanks B.J.) the headaches and run all the way to the battery from the beginning. Once you get it in and programmed, the system is SWEET!!!!!!!

  • #2
    RE: Ride Pro e Install Tips

    Good looking out!!

    Comment


    • #3
      [Deleted]

      [Deleted by Admins]

      Comment

      Working...
      X